作業内容を保存する

set.a.light 3D のプロジェクトは、拡張子 .set の1つのファイルです。撮影全体が含まれます。タイムラインのすべてのショット、その中のすべてのオブジェクト、プロジェクトが必要とするリソースです。レンダリングした画像は、そのファイルの隣にあるフォルダーに保存されます。このページでは、保存の方法、作業中にプログラムが書き出す復旧用コピー、プログラムの外へ出す方法を説明します。

適用対象 BASIC、STUDIO、CINEMA · 必要なもの:開いているプロジェクト。ここに出てくるキーはすべてデフォルトの割り当てで、設定 → ショートカット… で変更できます。

場所

保存と読み込みは、ファイルメニューにあります。

コマンド デフォルトのキー
新しいプロジェクト… Ctrl+N(macOS では Cmd+N)
プロジェクトを開く… Ctrl+O(Cmd+O)
プロジェクトを保存 Ctrl+S(Cmd+S)
プロジェクトを別名で保存… Ctrl+Shift+S(Cmd+Shift+S)
最近開いたファイル —
ファイルメニューからのプロジェクトの保存と読み込み
ファイルメニューからのプロジェクトの保存と読み込み

スタートウインドウのワークスペースタブにも最近開いたファイルが表示されるため、何かを開く前に、前回の続きから始められます。

プロジェクトを保存する手順

  1. 初回はファイル → プロジェクトを別名で保存…を選び、フォルダーと名前を指定します。→ ディスク上に2つのものができます。プロジェクトである <name>.set と、このプロジェクトのレンダリング画像用の、その隣のフォルダー <name>/ です。
  2. 以降は、Ctrl+S で同じファイルに書き込みます。プロジェクトに専用のファイルができるまで、プロジェクトを保存はグレーのままです。

撮影を移動したりバックアップしたりするときは、この2つをまとめて扱ってください。.set ファイルだけでプロジェクトとして完結しますが、レンダリングした画像はフォルダーの中にあります。

.set ファイルに含まれるもの、含まれないもの

このファイルは圧縮されたコンテナで、中身を参照できるフォルダーではありません。自分で用意した素材のうち、プロジェクトに必要なものはすべてファイルの中に入っています。プログラムに付属するカタログのものは、コピーされず参照だけが保存されます。受け取る側にも同じものがあるためです。完全な一覧は、プロジェクトファイルを扱うプロジェクトを作成、開く、保存するにあります。

設計上、2種類の素材はファイルの外に残ります。読み込んだ3Dオブジェクト(アドオン:3Dインポート)と、自分で用意した環境マップです。HDRIは容量の大きい画像ファイルで、保存のたびにプロジェクトに書き込まれてしまうためです。相手に必要な場合は、これらを別に送ってください。3Dオブジェクトを共有、更新、バックアップするを参照してください。

プログラムが尋ねる2つの確認

似ていますが、意味が違います。

2つの異なる確認:1つはファイルについて、もう1つはショットについて
2つの異なる確認:1つはファイルについて、もう1つはショットについて
  • 保存されていない変更に 保存、別名で保存、破棄、キャンセルが並ぶ場合は、ファイルについての確認です。変更がまだディスクに保存されていないプロジェクトを、閉じる、または別のプロジェクトに置き換えようとしています。保存が表示されるのは、プロジェクトに専用のファイルができてからです。
  • 保存されていない変更に 適用、新しいショット、破棄、キャンセルが並ぶ場合は、ショットについての確認です。ショットを撮ったあとにスタジオを変更し、そのショットから離れようとしています。適用は変更をそのショットに書き込み、新しいショットは変更を残して、変更後の状態を2つ目のショットとして保存します。ショットを作成して管理するを参照してください。

作業中の復旧用コピー

set.a.light 3D は、作業中に、開いているプロジェクトの復旧用コピー(自動保存)を書き出します。初期状態でオンになっています。

プログラム設定にある2つの自動保存の項目
プログラム設定にある2つの自動保存の項目

次のクリップでは、同じ設定ページの下部にある2つの項目に、0:43 で到達します。

You are currently viewing a placeholder content from YouTube. To access the actual content, click the button below. Please note that doing so will share data with third-party providers.

More Information

  • 自動保存を有効にする — オンまたはオフ。
  • 自動保存の遅延 — 1 〜 60 分、デフォルトは5分です。最初に保存されていない変更が生じた時点から計測が始まります。

どちらも、設定 → 設定… → プログラム設定から開きます。これはアプリマネージャーボタンで開くのと同じウインドウの、別のページです。

最初の日に知っておきたいことが2つあります。1つ目は、コピーがプロジェクトの隣ではなく、1か所の共通のフォルダーに保存されることです。ヘルプ → 自動保存フォルダーを表示で開けます。ファイル名には、プロジェクト名に加えて保存場所を表す印が付くため、同じ名前の2つのプロジェクトが互いを上書きすることはありません。2つ目は、このフォルダーに残るのは10件までということです。次回の起動時に古いものから削除されてこの数に収まるため、必要なものは別の場所に移してください。ファイル → 自動保存を削除は、開いているプロジェクトのコピーだけを削除します。

そのほかの規則は、プロジェクトを作成、開く、保存するにあります。コピーがいつ書き出され、いつ待機するか、通常のプロジェクトを保存でコピーが残る理由、プロジェクトを再び開いたときの自動保存ありダイアログがコピーをどう扱うかです。

プログラムに障害が発生した場合は、救出用のプロジェクトとログも、ドキュメントフォルダー内の elixxier フォルダーに書き込まれます。ファイル名は CRASH_<date>_<time>_<project>.set です。復旧までの手順は、クラッシュ後にプロジェクトを復元するで説明しています。

プログラムの外へ出す方法

成果物を作る前にプロジェクトを保存しておくと、ファイルの置き場所が安定します。これは技術的な要件ではなく、望ましい習慣です。保存していないプロジェクトでも、レンダリングやセットプランは動作しますが、出力は思いもよらない場所に保存されます。

目的 方法 詳細
完成した画像 レンダータブ → 画像をレンダリング 画像の保存先
実際の撮影用のプラン プランタブ → PDFまたは画像ページとして書き出し セットプランを作成する
カメラワークを映像にする アニメーションエディタ → ビデオをレンダリング(アドオン:Animation Tool) 出力されるビデオファイル
セットアップを他の人に見せる コミュニティタブ → 共有ウィザード ショットをコミュニティで共有する
別のコンピューターに設定とプリセットを移す ファイル → ユーザー設定をエクスポート… 設定
読み込んだ3Dオブジェクト ファイル → マイ3Dオブジェクトをエクスポート…(アドオン:3Dインポート) 3Dオブジェクトを共有、更新、バックアップする

プログラムが書き出すもの

対象 ファイルタイプ 備考
アニメーションまたはカメラワーク MP4 H.264ビデオ。フレームレートはタイムラインから取得(毎秒2〜120フレーム)
最終レンダリングとアニメーションのフレーム JPG 最高のJPG画質。露出データをファイルに書き込む
プロジェクトとセット .set
セットプランのPDF PDF
セットプランの画像(ページごとに1ファイル) JPG ページごとに1ファイル。選択したフォルダーに保存
スナップショットに保存されるレンダリング JPG 最高のJPG画質。露出データをファイルに書き込む
ユーザー設定、リソース、プリセット .xdat 別のコンピューターに移せる単一のアーカイブ

ヒントと制限

  • 編集 → .setファイルを追加は、別のプロジェクトを開いているプロジェクトに統合します。2つの撮影をまとめる実用的な方法です。プロジェクト間でショットを移動するを参照してください。
  • BASIC以外では、セットを開始用のシーンとして保存できます。編集 → 現在のセットをテンプレートとして保存を実行すると、スタートウインドウの自分のテンプレートタブに追加されます。
  • 新しいバージョンのプログラムで書き出されたプロジェクトは、古いバージョンでは開けません。古いファイルは、読み込み時に新しい形式へ移行されます。

トラブルシューティング

  • プロジェクトの保存に失敗しました。 保存先のフォルダーに書き込めないか、ドライブが接続されていません。ダイアログには再試行が表示されます。フォルダーの問題を解決してから押してください。キャンセルをクリックすると、変更を残したままプロジェクトに戻り、行おうとしていた操作(新しいプロジェクトの作成、別のファイルを開く、終了)は中止されるため、何も失われません。プロジェクトを別名で保存…で別のフォルダーを指定する方法もあります。→ 何かおかしいと思ったら:まずここから
  • プロジェクトの読み込みに失敗しましたと、新しいバージョンについての注記が表示される場合は、お使いのビルドより新しいビルドで作られたファイルです。→ set.a.light 3D をアップデートする
  • セッションが中断され、作業内容を元に戻したい。 → クラッシュ後にプロジェクトを復元する

関連項目